JDK的不同版本,很容易导致工程编译和启动报错,特别是项目里面没有统一使用某一类的第三方包,版本冲突等导致工程启动时各种异常。

Java有时候竟变成了一处编译,到处调试的情况,所以最好是组里面所有人统一使用同一个版本的JDK和第三方包。有了maven之后好了很多,但如果管理不善还是会出现这样的问题的。

JDK的老版本如1.6 1.7的下载地址很难找,今天给组里面的人搭环境的时候,也遇到了这种问题,没有找他们要安装包是因为他们都是linux环境,现需要搭建一个新的windows开发环境。

下面是JDK 老版本的下载方式:

  1. 根据jdk版本,在google搜索关键字。如:jdk 1.7.0_65,搜索 JDK 7u65
  2. 点击 Java Archive Downloads 链接(一般是第一条结果),在新页面选择对应的版本 Java SE Development Kit 然后下载
  3. 注意下载版本:linux | windows、i586(32位) | x64(64位) | ia64(inter的一种,与x86-64不兼容)

刚发现百度经验上有一篇介绍,也很方便。地址:如何在官网下载java JDK的历史版本